Условные операции 1С и булево 1С

Также на эту тему:
Переменные 1С
Функции 1С и процедуры 1С
Циклы в 1С
Обработка ошибок 1С (Попытка-Исключение)
Объекты 1С и ссылки 1С

Дополнительные материалы:
Электронная книга "Язык 1С. Том 1"

Значение Булево 1С — это значение Истина или Ложь. В числовом выражении Ложь это ноль, а Истина — число больше нуля (обычно единица).

Выражение (операция) Булево 1С — это математическое выражение, результатов которого является значение типа Булево 1С, например:
a = 0+1;
b = 2-1;
x = (a = b);
//x = Истина

Далее — подробнее о условных операциях 1С, значениях и выражениях булево 1С.


Условная операция 1С ЕСЛИ выглядит следующим образом:
Если ОПЕРАЦИЯ-БУЛЕВО Тогда
     //действия1…
ИначеЕсли ОПЕРАЦИЯ-БУЛЕВО Тогда
     //действия2…
Иначе
     //действия3…
КонецЕсли;

Булево 1С — это результат вычисления со значениями Истина или Ложь, например:
Массив1 = Новый СписокЗначений();
Если Массив1.Количество() > 0 Тогда
     //действия…
КонецЕсли;

//другой вариант, полностью аналогичный
Если НЕ Массив1.Количество() = 0 Тогда
     //действия…
КонецЕсли;

Многие функции/методы объектов возвращают успешность выполнения операции как булево 1С, например:
Запрос = Новый Запрос();
Выборка = Запрос.Выполнить().Выбрать();
Если Выборка.Следующий() Тогда
     //действия…
КонецЕсли;

В условной операции 1С можно объединять несколько условий с использованием И и ИЛИ:
Массив1 = Новый СписокЗначений();
Если (Массив1.Количество() > 0 и Массив1.Количество() < 10) или Массив.Количество() > 100 Тогда
     //действия…
КонецЕсли;

Условия булево 1С можно использовать непосредственно в коде программы:
Переменная1 = 5;
флгРезультат = (Переменная1 = 2 + 3); //флгРезультат будет равен ИСТИНА

В условной операции 1С оператор ЕСЛИ ИНАЧЕ ТОГДА можно заменить более кратким выражением. Следующие два варианта равны:


Только зарегистрированные пользователи VIP группы могут видеть этот контент.


У реквизитов объектов (справочников, документов и т.п.) есть возможность установить тип булево 1С. Также можно создать переменную булево 1С, например:
флгВыполнено = Истина;

Далее, в условиях ЕСЛИ, можно писать равнозначно двумя способами:
//вариант 1
Если флгВыполнено = Истина Тогда
     //делаем что-то
КонецЕсли;

//вариант 2
Если флгВыполнено Тогда
     //делаем что-то
КонецЕсли;

Второй вариант таит в себе следующую «неприятность»:


Только зарегистрированные пользователи VIP группы могут видеть этот контент.




Проголосовать за этот пост:

1 Star2 Stars3 Stars4 Stars5 Stars (2 голосов, среднее: 5,00 из 5)
Loading ... Loading ...

Также на эту тему:
Переменные 1С
Функции 1С и процедуры 1С
Циклы в 1С
Обработка ошибок 1С (Попытка-Исключение)
Объекты 1С и ссылки 1С
Метаданные 1С
Коллекции значений 1С

Дополнительные материалы:
Электронная книга "Язык 1С. Том 1"

Добавить комментарий