Файл 1С

Также на эту тему:
Работа с файлами 1С
ДиалогВыбораФайла 1С
КаталогВременныхФайлов 1С и
ПолучитьИмяВременногоФайла 1С

Работа с файлами в тонком клиенте -
получить/поместить файл, временное хранилище

Работа с файловой системой из 1С

Дополнительные материалы:
Электронная книга "Язык 1С. Том 1"

Объект языка 1С «Файл» позволяет:

  • файл 1С — получить путь к файлу (каталог без имени файла), имя без расширения, только расширение
  • файл 1С — проверить наличие файла
  • файл 1С — определить файл это или каталог
  • файл 1С — получить размер файла
  • файл 1С — работать с атрибутами файла (время измененеия, только чтение, скрытые файлы).


Пример файл 1С — проверка наличия каталога на диске:
Функция ПолучитьКаталогПоИмениФайла(ИмяФайла)

//обращаемся к файлу, на этот момент существование файла не проверяется
Файл = Новый Файл(ИмяФайла);

//напрямую проверяем существование
Если не Файл.Существует() Тогда
Сообщить("Ошибка. Файл с именем '" + ИмяФайла + "' не существует");
Возврат ИмяФайла;
КонецЕсли;

//проверка на каталог
Если Файл.ЭтоКаталог() Тогда
//если последняя буква не "\", то добавляем ее
Возврат ?(Прав(СокрП(ИмяФайла), 1) = "\", ИмяФайла, СокрП(ИмяФайла) + "\");
КонецЕсли;

//возвращаем путь (т.е. только каталог из имени файла)
Возврат Файл.Путь;

КонецФункции

Пример файл 1С — проверка существования файла на диске:
Функция ФайлМожноЗаписывать(ИмяФайла)

//обращаемся к файлу, на этот момент существование файла не проверяется
Файл = Новый Файл(ИмяФайла);

//напрямую проверяем существование
Если не Файл.Существует() Тогда
Сообщить("Ошибка. Файл с именем '" + ИмяФайла + "' не существует");
Возврат ИмяФайла;
КонецЕсли;

//вернет ИСТИНА, если нельзя записывать (т.е. только чтение "установлен")
Если Файл.ПолучитьТолькоЧтение() Тогда
Попытка
Файл.УстановитьТолькоЧтение(Ложь);
Исключение
//здесь мы окажемся, если у пользователя, под которым работает клиент 1С нет прав снять этот реквизит
Возврат Ложь;
КонецПопытки;
КонецЕсли;

Возврат Истина;

КонецФункции

Пример файл 1С — получение размера файла в байтах, килобайтах, мегабайтах:


Только зарегистрированные пользователи VIP группы могут видеть этот контент.




Проголосовать за этот пост:

1 Star2 Stars3 Stars4 Stars5 Stars (2 голосов, среднее: 1,00 из 5)
Loading ... Loading ...

Также на эту тему:
Работа с файлами 1С
ДиалогВыбораФайла 1С
КаталогВременныхФайлов 1С и
ПолучитьИмяВременногоФайла 1С

Работа с файлами в тонком клиенте -
получить/поместить файл, временное хранилище

Работа с файловой системой из 1С
Текстовые файлы 1C -
ЧтениеТекста и ЗаписьТекста 1С,
ЗначениеВФайл и ЗначениеИзФайла 1С

XML файлы 1С - ЧтениеXML и ЗаписьXML 1С
XML DOM 1С - ПостроительDOM и ЗаписьDOM 1С
Картинка 1С
ДвоичныеДанные 1C,
Base64Строка и Base64Значение 1C


Дополнительные материалы:
Электронная книга "Язык 1С. Том 1"

Добавить комментарий